Triton Digital incident: support.tritondigital.com issues
Incident Report for Triton Digital
Resolved
The new temporary support center is now fully operational.
Posted 27 days ago. Jan 29, 2018 - 18:36 UTC
Update
We are currently working on enabling a new support page with a form to submit your cases. More information will be made available shortly.
Posted 27 days ago. Jan 29, 2018 - 15:55 UTC
Identified
Identified:

We have found that our Support website located at support.tritondigital.com is not responding properly. While we are working with this issue, please be advised that you can always contact us directly by sending email to: supportdesk@tritondigital.com or via telephone at 866-448-4037

More information will follow
Posted 27 days ago. Jan 29, 2018 - 13:14 UTC