Tap Inventory Avails Service Degradation
Incident Report for Triton Digital Platform Status
Resolved
All forecasting servers are now fully operational.
Posted Feb 22, 2018 - 22:28 UTC
Investigating
One of our forecasting servers is currently experiencing some issues.
We will update as we continue to troubleshoot.
Posted Feb 22, 2018 - 21:52 UTC