Triton Digital incident: Webcast Metrics
Incident Report for Triton Digital Platform Status
Resolved
Webcast Metrics missing data has been fully reprocessed. Thanks for your patience.
Posted Feb 20, 2018 - 16:55 UTC
Identified
We have identified an issue with Webcast Metrics daily data processing and are working to resolve the issue. More information will follow.
Posted Feb 17, 2018 - 21:20 UTC