Navigator – Reports returning "no data available".
Incident Report for Triton Digital Platform Status
Resolved
Resolved: The issue with Navigator has been identified and fixed. Data is now available.
Posted Feb 21, 2018 - 18:37 UTC
Investigating
Investigating: The service providing data information to Navigator is currently experiencing an issue. More information will follow.
Posted Feb 21, 2018 - 16:11 UTC