Triton Digital incident: Telephone System Issues
Incident Report for Triton Digital
Resolved
Resolved: The telephone system is stable, we are marking this incident as resolved.
Posted 2 months ago. Sep 06, 2017 - 18:59 UTC
Monitoring
Monitoring: We have identified the issues on our telephone system and have implemented a fix which has restored telephone service. We will continue to monitor the situation closely.
Posted 2 months ago. Sep 06, 2017 - 18:27 UTC
Investigating
Investigating - We are currently unable to receive calls in to our phone system. Details and updates will follow. To contact us for a support-related issue, please send us a case at supportdesk@tritondigital.com.
Posted 2 months ago. Sep 06, 2017 - 16:59 UTC