Now Playing information delayed
Incident Report for Triton Digital Platform Status
Resolved
This incident has been resolved.
Posted Jun 19, 2019 - 23:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2019 - 20:19 UTC
Identified
The issue has been identified and a fix is being implemented. More updates to follow.
Posted Jun 19, 2019 - 19:23 UTC
Investigating
We are currently investigating an issue with our Now Playing Service being delayed. More information will follow.
Posted Jun 19, 2019 - 13:49 UTC
This incident affected: AMERICAS (East - Live Streaming Delivery).