Trouble Ticket System Issues
Incident Report for Triton Digital
Resolved
Our ticketing vendor has resolved this issue. We have verified this situation no longer is impacting our Ticketing system.
Posted 11 days ago. Aug 09, 2017 - 20:04 UTC
Update
Trouble ticket emails are still impacted by this issue. Our ticketing system vendor is investigating this issue, we will continue to update you as we develop further information.
Posted 11 days ago. Aug 09, 2017 - 19:24 UTC
Investigating
We are currently investigating an issue with our Trouble Ticket system, you may not receive an immediate reply to your submissions.
If you have a Stream Down emergency please call us on our regular line: 866-448-4037 option #1

We will update this report as we develop more information.
Posted 11 days ago. Aug 09, 2017 - 18:24 UTC