Triton Digital incident: Tap Inventory Avails Service Degradation
Incident Report for Triton Digital Platform Status
Resolved
All forecasting servers are now fully operational.
Posted Mar 09, 2018 - 00:48 UTC
Investigating
Investigating - One of our forecasting servers is currently experiencing some issues.
We will update as we continue to troubleshoot.
Posted Mar 08, 2018 - 21:41 UTC