New Notification Options for Triton Digital Status Page
Incident Report for Triton Digital Platform Status
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 16:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2020 - 12:35 UTC
Investigating
Subscribers! You can now edit your subscription selections!
Simply go through the subscription process again (click "Subscribe" and enter your contact info – you will not need to confirm) then select the components or products you want to subscribe to. Don't forget to click Save at the bottom.

For more information, see the Knowledge base article "How to get Statuspage alerts and notifications."
Posted May 29, 2020 - 20:17 UTC