Trouble ticket system issues
Incident Report for Triton Digital
Resolved
We have resolved the issue with the ticketing system vendor, all our normal support contact methods are restored to full service.
Posted 3 months ago. Aug 01, 2017 - 13:32 UTC
Investigating
We are currently investigating an issue with our Trouble Ticket system, you may not receive an immediate reply to your submissions. Additionally the webpage at http://support.tritondigital.com is not working.

If you have a Stream Down emergency please call us on our regular line: 866-448-4037 option #1

We will update this report as we develop more information.
Posted 3 months ago. Aug 01, 2017 - 11:54 UTC