Triton Digital incident: TAP UI
Incident Report for Triton Digital Platform Status
Resolved
This incident has been resolved.
Posted Oct 05, 2018 - 19:59 UTC
Monitoring
Service is up. We are monitoring.
Posted Oct 05, 2018 - 19:30 UTC
Investigating
Our TAP UI is running in a degraded mode. More information will follow.

Ad delivery is not impacted.
Posted Oct 05, 2018 - 19:20 UTC
This incident affected: AMERICAS (Legacy Tap UI).