Support emails not being processed
Incident Report for Triton Digital
Resolved
The support ticketing system is now functioning at 100% and we are receiving all new cases.
Posted 2 months ago. Oct 03, 2017 - 15:54 UTC
Identified
We are now receiving all new cases submitted to the support ticketing system. The backlog of cases sent from this morning are still being processed.
Posted 2 months ago. Oct 01, 2017 - 17:18 UTC
Investigating
We are looking into reports of emails not being received in our Support ticketing system. For any stream down emergencies, please call our emergency number (1-800-939-9413) and leave a message.
Posted 2 months ago. Oct 01, 2017 - 13:37 UTC