Comcast outage, Eastern US and Canada
Incident Report for Triton Digital Platform Status
Resolved
This incident has been resolved.
Posted Jul 19, 2018 - 10:30 UTC
Investigating
We are receiving reports of streaming issues from across the Eastern US and Canada. We have found that there is a major Comcast outage being reported that is adversly impacting many end users in that area. This issue can be monitored at: http://downdetector.com/status/comcast-xfinity and we are in touch with our providers to ensurre that everything possible is being done.
Posted Jun 29, 2018 - 17:26 UTC