Triton Digital incident: TAP UI is down
Incident Report for Triton Digital
Resolved
Resolved: We have restored our Tap UI and it is now fully operational. Thank you for your patience.
Posted about 1 month ago. Dec 04, 2018 - 19:59 UTC
Investigating
Investigating: Our TAP UI is running in a degraded mode. More information will follow.
Posted about 1 month ago. Dec 04, 2018 - 17:08 UTC
This incident affected: Advertising Platform (Tap UI).