Latency in London
Incident Report for Triton Digital
Resolved
Incident Resolved. The network is again operational.
Posted Mar 15, 2020 - 14:27 UTC
Investigating
We are currently investigating latency on our London servers. More information will follow.
Posted Mar 15, 2020 - 01:46 UTC
This incident affected: Content Delivery (Live Streaming).