Podcast delivery issues in South America
Incident Report for Triton Digital Platform Status
Resolved
We are marking this incident as resolved.
Posted Feb 24, 2020 - 14:23 UTC
Investigating
We are investigating reports of podcast delivery issues in South America. More information will follow.
Posted Feb 20, 2020 - 17:21 UTC
This incident affected: AMERICAS (Podcast Delivery).