Podcast delivery issue in South America
Incident Report for Triton Digital Platform Status
Resolved
This incident has been resolved.
Posted Aug 06, 2020 - 18:14 UTC
Monitoring
We have identified the root cause of this issue and are monitoring this situation.
Posted Aug 05, 2020 - 12:52 UTC
Identified
We have identified an issue impacting podcast delivery in South America.
Posted Aug 05, 2020 - 00:10 UTC
This incident affected: AMERICAS (Podcast Delivery).