Issue with editing tags in Sounder

Incident Report for Triton Digital Platform Status

Resolved

No further issues have been observed and the incident is now considered resolved.
Posted Apr 15, 2026 - 14:09 UTC

Monitoring

A fix has been applied. Users should once again be able to edit tags in Sounder.
We will be monitoring the situation closely.
Posted Apr 14, 2026 - 21:42 UTC

Investigating

We are currently investigating an issue when selecting the Edit option to edit a tag in the Sounder UI does not open the editing options.
Posted Apr 14, 2026 - 19:27 UTC
This incident affected: EMEA (Sounder), AMERICAS (Sounder), and APAC (Sounder).