TAP Programmatic - New deals created with BidSwitch not running as intended

Incident Report for Triton Digital Platform Status

Resolved

Only deals configured via BidSwitch with the “Ignore bidder seat” setting enabled in TAP UI were affected.
We have disabled this setting, and delivery has resumed.
This incident is now resolved.
Posted Jan 15, 2026 - 16:55 UTC

Investigating

We've gotten reports of deals with Bidswitch created since December that are not running as intended. Our teams are investigating the situation.
Posted Jan 15, 2026 - 14:29 UTC
This incident affected: EMEA (Programmatic Ad Delivery), AMERICAS (Programmatic Ad Delivery), and APAC (Programmatic Ad Delivery).