Ad server latencies resulting in increased delivery of safeguard in North America
Incident Report for Triton Digital Platform Status
Resolved
This incident has been resolved.
Posted Jul 29, 2021 - 19:22 UTC
Update
Final optimization efforts have been applied. Our monitoring tools show that they have been successful in reducing ad serving latency back to normal levels.
We are closely monitoring the situation.
Posted Jul 23, 2021 - 15:50 UTC
Update
We have performed additional optimizations of the ad serving platform. We are hopeful that these will help soothe out the latency spike.
More information to follow.
Posted Jul 23, 2021 - 01:10 UTC
Update
Note: This issue can have an effect on listener connection times. An increase of as much as 5 seconds could be experienced in the time to start a stream depending on various factors.

We continue to see sporadic spikes of latency in the ad preparation of some ad servers. While we are pushing on with our efforts to further reduce these spikes
More information to follow.
Posted Jul 22, 2021 - 17:55 UTC
Update
Our latest optimization efforts have had a positive impact in reducing ad server latencies. However, there remains a number of areas where further effort is needed. We will be performing addition manipulations towards restoring ad serving to its normal operating levels.
More information to follow.
Posted Jul 21, 2021 - 18:45 UTC
Update
We are continuing our efforts for further optimization of the ad servers as well as monitoring key safeguard indicators.
More information to follow as we progress with our efforts.
Posted Jul 21, 2021 - 12:59 UTC
Update
We have performed a number of manipulations on the platform which we hope will help mitigate the issue. While we are monitoring the status of the ad server latency, we are also exploring further optimization options.
Posted Jul 20, 2021 - 23:23 UTC
Update
Note: We have become aware that this issue is affecting in-stream pre-roll delivery. In-stream pre-rolls might not be inserted due to the high ad server latency.

Our team continues to work on getting the performance of the ad servers back to normal levels. We are treating this issue with the highest level of attention and effort.
More information to follow.
Posted Jul 20, 2021 - 21:02 UTC
Update
We have been applying various measures to decrease the latency in our ad servers and therefore reduce the amount of safeguard that is being delivered. While we have made significant progress and have reduced the impact of the issue, we are not fully back to normal levels. We are continuing our efforts to fully resolve the situation.
More information to come.
Posted Jul 20, 2021 - 01:12 UTC
Investigating
We are currently investigating an issue with latency in the ad delivery servers. This is resulting in unusually high levels of Safeguard being inserted. Stations without safeguard may be heard returning to live early.
We are actively working on fixing the issue.
More information to follow.
Posted Jul 19, 2021 - 19:08 UTC
This incident affected: AMERICAS (Live Streaming Ad Delivery).