TAP users having issues duplicating or copying flights
Incident Report for Triton Digital
Resolved
This incident has been resolved.
Posted Oct 11, 2019 - 15:33 UTC
Investigating
We are currently investigating reports of users being unable to copy or duplicate a flight in the TAP UI
More information will follow.
Posted Oct 10, 2019 - 17:59 UTC
This incident affected: Advertising Platform (Tap UI).