Rare instances of live streaming subject to listener drops
Incident Report for Triton Digital Platform Status
Resolved
This incident is considered resolved.
Posted Jun 30, 2022 - 17:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2022 - 13:37 UTC
Identified
We have identified an error in the code that could potentially explain those crashes. We are deploying a Hotfix in a handful of servers overnight and will decide in the coming days if it's a fix we should deploy everywhere or not.
Posted Jun 20, 2022 - 19:23 UTC
Investigating
In rare instances, our live stream (media gateway) servers using our latest software version can result in a reboot of the service, affecting all listeners connected to that server. Listeners dropped during the reboot will reconnect to other servers but in some circumstances may have trouble reconnecting.

We know that this issue is related to the new code, but haven't yet identified how to reproduce the issue. We are working on a release to fix it.
Posted Jun 17, 2022 - 15:59 UTC
This incident affected: AMERICAS (East - Live Streaming Delivery, West - Live Streaming Delivery, Podcast Delivery, Live Streaming Ad Delivery, On-Demand Ad Delivery, Podcast Ad Delivery, Yield-Op Ad Delivery, Legacy Tap UI, TAP UI, Tap Reporting, Tap Reporting - Inventory Availability Forecasting, Tap Explore, Media Buying API, Order Management System (OMS) Proxy, Yield-Op UI, Yield-Op Analytics Dashboard (Rill), Yield-Op Scheduled Reports, 3rd Party Trackers & Programmatic Impressions, Metrics API (Advertising + Measurement), Podcast Metrics UI, Streaming Metrics UI, Webcast Metrics UI, Webcast Metrics API, Data Collection Services (LT / LC), Omny Studio Management Portal, Omny Studio Management API, Omny Campaign Manager, Omny.fm Publishing, Single Sign On Services, Login services, Custom Reports, Omny Campaign Manager Forecasting Tool, Triton Console, 3rd party cookie synchronization, Omny Studio Webhooks Service, Data Export Services), EMEA (Live Streaming Delivery, Podcast Delivery, Live Streaming Ad Delivery, On-Demand Ad Delivery, Podcast Ad Delivery, Yield-Op Ad Delivery, Legacy Tap UI, Tap Reporting, Tap Reporting - Inventory Availability Forecasting, Tap Explore, Media Buying API, Order Management System (OMS) Proxy, Yield-Op UI, Yield-Op Analytics Dashboard (Rill), Yield-Op Scheduled Reports, 3rd Party Trackers & Programmatic Impressions, Metrics API (Advertising + Measurement), Podcast Metrics UI, Streaming Metrics UI, Webcast Metrics UI, Webcast Metrics API, Data Collection Services (LT / LC), Omny Studio Management Portal, Omny Studio Management API, Omny Campaign Manager, Omny.fm Publishing, Single Sign On Services, Login services, Custom Reports, Omny Campaign Manager Forecasting Tool, Triton Console, 3rd party cookie synchronisation, TAP UI, Omny Studio Webhooks Service, Data Export Services), and APAC (South East & Pacific - Live Streaming Delivery, South - Live Streaming Delivery, Podcast Delivery, Live Streaming Ad Delivery, On-Demand Ad Delivery, Podcast Ad Delivery, Yield-Op Ad Delivery, Legacy Tap UI, TAP UI, Tap Reporting, Tap Reporting - Inventory Availability Forecasting, Tap Explore, Media Buying API, Order Management System (OMS) Proxy, Yield-Op UI, Yield-Op Analytics Dashboard (Rill), Yield-Op Scheduled Reports, 3rd Party Trackers & Programmatic Impressions, Metrics API (Advertising + Measurement), Podcast Metrics UI, Streaming Metrics UI, Webcast Metrics UI, Webcast Metrics API, Data Collection Services (LT / LC), Omny Studio Management API, Omny Studio Management Portal, Omny Campaign Manager, Omny.fm Publishing, Single Sign On Services, Login services, Custom Reports, Omny Campaign Manager Forecasting Tool, Triton Console, 3rd party cookie synchronisation, Omny Studio Webhooks Service, Data Export Services).