Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 30, 2026 - 17:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 27, 2026 - 17:23 UTC
Scheduled
A software maintenance will take place on Monday, March 30th, 2026 from 13:30 to 14:30 UTC.
This update introduces the following changes: - Back-end modification to add the capability to excluding ads that are related to IAB category 24 (uncategorized). - Preparations to enable Brand safety and suitability features.
Please note that there should be no interruptions to ad-serving or reporting data collection during this maintenance.
Best Regards, Your Triton Digital Team
Posted Mar 30, 2026 - 13:30 UTC
This scheduled maintenance affected: EMEA (Live Streaming Ad Delivery, Podcast Ad Delivery, On-Demand Ad Delivery), AMERICAS (Live Streaming Ad Delivery, Podcast Ad Delivery, On-Demand Ad Delivery), and APAC (Live Streaming Ad Delivery, Podcast Ad Delivery, On-Demand Ad Delivery).