TAP UI : Safeguard Management page not accessible
Incident Report for Triton Digital
Resolved
Resolved: Our Safeguard Management Page is now accessible.
There is no impact on impressions records
There is no impact on Ad delivery
Posted 15 days ago. Oct 03, 2017 - 19:02 UTC
Investigating
Investigating: Our Safeguard Management Page is currently not accessible and returning an error.
There is no impact on impressions records
There is no impact on Ad delivery

More information will follow
Posted 15 days ago. Oct 03, 2017 - 17:52 UTC