Data Query Time Outs or Slow For Certain User Interfaces
Incident Report for Triton Digital Platform Status
Resolved
In the past months, our teams have been hard at work pushing various platform and product optimizations. These efforts have greatly reduced query times as well as the stress of large queries on our data mining tools.
At this time, we are closing this incident as no further major issues have been reported due to data queries.
Posted Jul 27, 2022 - 18:29 UTC
Update
Our team has scoped out several initiatives to improve the inner workings of our various data query mechanisms. These initiatives are currently in the planning phase and could take several weeks to be finalized and deployed to our platform.
In the mean time, client might still experience sporadic problems (No data or Errors) in the UI during certain peak hours (usually between 13:00 to 16:00 UTC and 19:00 and 21:00 UTC).
We continue to apply mitigation measures where and when we can to eliviate the situation until the optimization initiatives can be deployed.
Posted May 26, 2022 - 20:59 UTC
Update
We are seeing another spike of data query request timing out and causing display issues in our various UI. Our team is currently evaluating further mitigation measures.
More information to follow.
Posted May 25, 2022 - 18:32 UTC
Update
Our monitoring has shown that data queries to our various products are running as except for peak usage hours which occur in North American morning (from 13:00 to 16:00 UTC which is around 9:00 to 12:00 EST). Users running large queries during those times might experience issues where they get an error message or "No Data" as a result of the query. We advise these users to wait a few minutes and retry their query.
Our teams have identified several data optimization initiatives which are being added to our various development sprints. The situation should improve as these initiatives are deployed over the coming days.
More information to follow.
Posted May 17, 2022 - 15:06 UTC
Identified
We have identified the cause of the issue and area applying mitigation measures.
The majority of queries should be running a bit smoother now and data should be showing. Large queries might still have issues completing. If your query results in No Data, please wait a minute and re-run your query. The situation should improve in the following hours.
More information to follow.
Posted May 12, 2022 - 22:06 UTC
Investigating
We have become aware of an issue with some of our data mechanisms which is causing certain user interfaces to be slow or show no data when making queries. Please note that no data loss is being incurred by this issue.

Affected components are as follows:
- Podcast Metrics
- Webacst Metrics
- Streaming Metrics (excluding Realtime stats and audience pages)
- Tap Forecasting
- Tap Explore

More information to come.
Posted May 12, 2022 - 20:17 UTC
This incident affected: EMEA (Tap Reporting, Tap Reporting - Inventory Availability Forecasting, Tap Explore, Streaming Metrics UI, Webcast Metrics UI, Webcast Metrics API), AMERICAS (Tap Reporting, Tap Reporting - Inventory Availability Forecasting, Tap Explore, Podcast Metrics UI, Streaming Metrics UI, Webcast Metrics UI), and APAC (Tap Reporting, Tap Reporting - Inventory Availability Forecasting, Tap Explore, Podcast Metrics UI, Streaming Metrics UI, Webcast Metrics UI).