Issues logging in to Triton Ad Platform, Metrics and other products
Incident Report for Triton Digital
Resolved
This incident has been resolved.
Posted May 19, 2020 - 09:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2020 - 08:27 UTC
Update
We are continuing to investigate this issue.
Posted May 19, 2020 - 08:08 UTC
Update
We are continuing to investigate this issue.
Posted May 19, 2020 - 08:02 UTC
Investigating
We have been alerted to an issue with login attempts not working for several products and are investigating.
Posted May 19, 2020 - 08:01 UTC
This incident affected: Omny Studio (Omny Campaign Manager), Advertising Platform (Tap UI), and Measurement Platform (Podcast Metrics).