Montreal Data Centre Networking issue

Incident Report for Triton Digital Platform Status

Resolved

The replacement equipment has been installed, configured and is online.
This incident is considered resolved.
Posted Jan 01, 2026 - 02:38 UTC

Identified

The problem has been found to be a faulty network switch. We are replacing the equipment.
Impact on listeners should be minimal.
More information to come.
Posted Dec 31, 2025 - 23:21 UTC

Investigating

We are currently investigating a network connectivity problem in our Montreal data centre.
Listener and client impact should be minimal. Our team is working to restore network connectivity as soon as possible.
More information to come.
Posted Dec 31, 2025 - 20:31 UTC
This incident affected: AMERICAS (Live Streaming Delivery - East).