Intermittent errors when using user creation

Incident Report for Triton Digital Platform Status

Resolved

This incident is considered resolved.
Posted Aug 19, 2025 - 19:49 UTC

Monitoring

The cause was identified and a fix has been applied. We are monitoring the situation closely.
Posted Aug 19, 2025 - 17:40 UTC

Investigating

We are currently investigating an issue where the user creation mechanisms in Settings and Tap are not working as intended. Clients may intermittently see a 404 error upon trying to create new users in Settings. Additionally, clients may see "invalid username: bad request" when attempting to add an existing Settings user to TAP.
More information to follow.
Posted Aug 19, 2025 - 13:30 UTC
This incident affected: EMEA (TAP UI, Settings UI), AMERICAS (TAP UI, Settings UI), and APAC (TAP UI, Settings UI).