Support Desk temporarily email unavailable (please use the online form)
Incident Report for Triton Digital Platform Status
Resolved
We have worked through our backlog and are operating normally.
This issue has been resolved.
Posted Sep 21, 2021 - 14:22 UTC
Update
While this issue has been resolved, we continue to work through the accumulated backlog of issues. We apologize for any delay in response to your tickets.
Posted Sep 16, 2021 - 20:23 UTC
Update
PLEASE NOTE: We have become aware of a problem when replying to supportteam@salesforce.tritondigital.com. This issue has been fixed. However, any reply made to this address since September 14 11:00 AM UTC will not have reached our ticketing system. Please resend any communication to us and we will do our best to promptly respond.
We apologize for this inconvenience.
Posted Sep 15, 2021 - 19:08 UTC
Update
PLEASE NOTE: We have become aware that any email sent to supportdesk@tritondigital.com yesterday between 11:00 AM UTC and 20:30 UTC will not have made its way to our ticketing system. If you sent us a message/ticket during this time, please resend it and we will do our best to help you in a timely manner.
We apologize for this inconvenience.
Posted Sep 15, 2021 - 13:27 UTC
Monitoring
Service has been restored to our ticketing system's email. You may now use supportdesk@tritondigital.com to open tickets and correspond with our Support Staff.
Please bear with us as we go through a rather large backlog of tickets. You might experience a longer than normal delay in an agent addressing your issue. If you need urgent assistance, please use the Emergency Support procedure (https://tritondigitalcommunity.force.com/s/article/How-to-Contact-Customer-Support?language=en_US#emergency)
Thank you for your understanding.
Posted Sep 14, 2021 - 20:33 UTC
Update
Our team continues to work on restoring email functionality to our Ticketing system.
Note that tickets can still be opened via the web form (https://tritondigitalcommunity.force.com/s/contactsupport?language=en_US) but our team is unable to respond to tickets.
We will progressively respond to tickets as soon as functionality is restored.
More information to follow.
Posted Sep 14, 2021 - 19:27 UTC
Investigating
We are aware of a problem with our ticketing system. At the moment, emailing supportdesk@tritondigital.com will not open a case in our ticketing system.
To reach our support team, please use the web form found at this URL: https://tritondigitalcommunity.force.com/s/contactsupport?language=en_US
We are actively working on restoring functionality to the email/ticketing system.
More information to follow.
Posted Sep 14, 2021 - 13:43 UTC