Omny Studio API/UI - Intermittent errors and slow performance

Incident Report for Triton Digital Platform Status

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2026 - 14:30 UTC

Investigating

We are investigating an issue impacting Omny Studio API and UI services. Some of our users can experience slowness and intermittent errors while navigating through the API/UI.
More information to come.
Posted Jan 20, 2026 - 13:58 UTC
This incident affects: EMEA (Omny Studio Management Portal, Omny Studio Management API), APAC (Omny Studio Management Portal, Omny Studio Management API), and AMERICAS (Omny Studio Management Portal, Omny Studio Management API).