Omny Podcast Embeds Not Functioning on Mozilla Firefox Browser

Incident Report for Triton Digital Platform Status

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 04:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2026 - 14:36 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 23, 2026 - 14:03 UTC

Investigating

We are currently aware of an issue affecting Omny Podcast Embeds, which are not functioning as expected when accessed through the Mozilla Firefox browser.

Clients and end users accessing Omny embedded podcast players via Firefox may experience failures in player playback functionality, resulting in Error Code 4.
Posted Apr 23, 2026 - 13:30 UTC
This incident affected: EMEA (Podcast Delivery), AMERICAS (Podcast Delivery), and APAC (Podcast Delivery).