TAP Programmatic UI intermittent errors

Incident Report for Triton Digital Platform Status

Monitoring

A fix has been deployed. We are seeing positive data suggesting that the fix is working and mitigating the timeouts properly.
We will monitor the situation closely.
Posted Jul 09, 2025 - 02:41 UTC

Identified

The issue's origin has been isolated to certain API queries the UI is making. We are currently developing mitigation measures to improve performance.
More information to come.
Posted Jul 08, 2025 - 17:26 UTC

Investigating

We are investigating an issue where TAP Programmatic is intermittently returning errors (500/504) or timing out.
This incident is not affecting ad delivery.
More information to come.
Posted Jul 07, 2025 - 18:53 UTC
This incident affects: AMERICAS (TAP Programmatic UI (Yield-Op)), APAC (TAP Programmatic UI (Yield-Op)), and EMEA (TAP Programmatic UI (Yield-Op)).