Vancouver Datacenter Network issue.

Incident Report for Triton Digital Platform Status

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2026 - 10:11 UTC

Investigating

We are currently investigating a networking issue in our Vancouver datacenter and evaluating the potential impact.
Posted Feb 20, 2026 - 08:06 UTC
This incident affects: AMERICAS (Live Streaming Delivery - West).