Login and Search functions in TAP
Incident Report for Triton Digital Platform Status
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 14:51 UTC
Monitoring
We have identified a problem with the TAP Database. The service has been recovered and we are monitoring.
Posted Oct 14, 2020 - 20:52 UTC