Issues with Ad Planning for On-Demand and Podcast Ad Delivery
Incident Report for Triton Digital Platform Status
Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 15:04 UTC
Monitoring
We have identified there was an issue that had impacted some flights delivery on the 19th and 20th of this month that is now resolved.
Posted Nov 22, 2020 - 05:05 UTC
Investigating
We are currently investigating an issue with our Advertising planning systems for podcast advertising. This may have an impact on some flights over-delivering or under-delivering. This could also impact some on-demand clients.
More information will follow.
Posted Nov 22, 2020 - 02:59 UTC
This incident affected: AMERICAS (On-Demand Ad Delivery, Podcast Ad Delivery).